关于我们

质量为本、客户为根、勇于拼搏、务实创新

< 返回新闻公共列表

网站安装用什么php版本?

发布时间:2019-10-22 07:17:32

PHP官网下载网站   php.net

【VC6与VC9的区别】:


VC6版本是使用Visual Studio 6编译器编译的。

VC9版本是使用Visual Studio 2008编译器编译的。

VC9版本主要用于IIS服务器;而VC6版本主要用于Apache服务器;

VC6和VC9只有在php5.3以前的版本有区分,从php5.3以后就只有VC9版本,VC6版本已经取消支持,因为过时了。

【TS与NTS的区别】:

Windows版的PHP从版本5.2.1开始有Thread Safe和NoneThread Safe之分。

Thread Safe是线程安全,执行时会进行线程(Thread)安全检查;Non Thread Safe是非线程安全,在执行时不进行线程(Thread)安全检查。

Apache+PHP的模式下,有两种比较常的加载方法:

1、用模块加载(Module load)PHP,就选择Thread Safe版本。

2、用FastCG加载PHP,就选择Thread Safe版本。

IIS+PHP的模式下,也有两种比较常的加载方法:

1、用ISAPI的方式来运行PHP就选择用Thread Safe版本。

2、用FastCGI模式运行PHP的话就选择用one Thread Safe版本。


【PHP 5.3】 

加入了很多有用的OOP特性!例如:匿名函数,SPL扩展不仅仅是迭代器,神话般的DateTime扩展都已经集成在PHP 5.3里面。还加入极其重要的E_DEPRECATED的错误报告标志。它会提醒您现在用的那些特性,将在下一版本无法使用。如果您已经在使用PHP 5.3,那么您往后的升级道路将会更加顺畅。如果您有线上程序运行在低版本,我不建议您升级。


【PHP 5.4】

进行了一系列的优化,它具有更快的执行效率和更少的内存占用。


/template/Home/Zkeys/PC/Static