关于我们

质量为本、客户为根、勇于拼搏、务实创新

< 返回新闻公共列表

Linux宝塔Nginx安装以及可能出现错误

发布时间:2019-10-23 09:41:25

从 http://nginx.org/download/nginx-1.9.15.tar.gz 下载nginx包(或者wget http://nginx.org/download/nginx-1.9.15.tar.gz直接在Linux上用命令下载)

解压并转到目录下

tar -zxvf nginx-1.9.15.tar.gz cd nginx-1.9.15

设置一下配置信息 ./configure --prefix=/usr/local/nginx ,或者不执行此步,直接默认配置

编译安装

make make install

make的过程是把各种语言写的源码文件,变成可执行文件和各种库文件; make install是把这些编译出来的可执行文件和库文件复制到合适的地方。

可能出现错误 
在配置信息./configure --prefix=/usr/local/nginx 的时,出现错误: 
/configure: error: the HTTP rewrite module requires the PCRE library. 
解决方法:安装pcre

yum -y install pcre pcre-devel

-y 是跳过所有需要手动确认的环节

缺少ssl错误,错误信息如下:

./configure: error: the HTTP cache module requires md5 functions from OpenSSL library. You can either disable the module by using --without-http-cache option, or install the OpenSSL library into the system, or build the OpenSSL library statically from the source with nginx by using --with-http_ssl_module --with-openssl= options.

解决方法:安装openssl

yum -y install openssl openssl-devel

缺少编译器,错误信息如下:

./configure: error: C compiler cc is not found

解决方法:安装gcc-c++

yum -y install gcc-c++ autoconf automake

autoconf是自动配置,automake是自动编译

缺少zlib包,错误信息如下:

./configure: error: the HTTP gzip module requires the zlib library. You can either disable the module by using –without-http_gzip_module option, or install the zlib library into the system, or build the zlib library

statically from the source with nginx by using –with-zlib= option. 
解决方法:安装zlib

yum install -y zlib-devel

确实libxml2,错误信息如下:

./configure: error: the HTTP XSLT module requires the libxml2/libxslt

libraries. You can either do not enable the module or install the libraries. 
解决方法:

yum -y install libxml2 libxml2-dev yum -y install libxslt-devel

http_image_filter_module是nginx提供的集成图片处理模块,需要gd-devel的支持,错误信息如下:

./configure: error: the HTTP image filter module requires the GD library. You can either do not enable the module or install the libraries.

解决方法:

yum -y install gd-devel


缺少ExtUtils,错误信息如下:

./configure: error: perl module ExtUtils::Embed is required

解决方法:

yum -y install perl-devel perl-ExtUtils-Embed

缺少GeoIP,错误信息如下:

./configure: error: the GeoIP module requires the GeoIP library. You can either do not enable the module or install the library.

解决方法:

yum -y install GeoIP GeoIP-devel GeoIP-data

检测是否安装成功

[root@localhost nginx-1.2.6]# cd /usr/local/nginx/sbin [root@localhost sbin]# ./nginx -t

启动nginx

[root@localhost sbin]# ./nginx

查看端口

[root@localhost sbin]# netstat -ntlp


打开浏览器访问此机器的 IP,如果浏览器出现 Welcome to nginx! 则表示 Nginx 已经安装并运行成功。



当时是下面错误用,了解决方法

http_image_filter_module是nginx提供的集成图片处理模块,需要gd-devel的支持,错误信息如下:

./configure: error: the HTTP image filter module requires the GD library. You can either do not enable the module or install the libraries.


解决方法:

yum -y install gd-devel



/template/Home/Zkeys/PC/Static